物理の駅 by onsanai

Physics Station → PhSt 質問・疑問・間違いの指摘は、コメントに書くか、直接伝えるときっと良いことがあります。主にWindows or Ubuntu用の記事です

Ubuntu に Nvidiaのドライバーを入れたときの E: Unable to correct problems, you have held broken packages. エラー

$ sudo apt install --just-print nvidia-driver-440
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nvidia-driver-440 : Depends: libnvidia-compute-440 (= 440.33.01-0ubuntu1) but 440.59-0ubuntu0.18.04.1 is to be installed
                     Depends: libnvidia-decode-440 (= 440.33.01-0ubuntu1) but it is not going to be installed
                     Depends: libnvidia-encode-440 (= 440.33.01-0ubuntu1) but it is not going to be installed
                     Recommends: nvidia-settings but it is not going to be installed
                     Recommends: nvidia-prime (>= 0.8) but it is not going to be installed
                     Recommends: libnvidia-compute-440:i386 (= 440.33.01-0ubuntu1)
                     Recommends: libnvidia-decode-440:i386 (= 440.33.01-0ubuntu1)
                     Recommends: libnvidia-encode-440:i386 (= 440.33.01-0ubuntu1)
                     Recommends: libnvidia-ifr1-440:i386 (= 440.33.01-0ubuntu1)
                     Recommends: libnvidia-fbc1-440:i386 (= 440.33.01-0ubuntu1)
                     Recommends: libnvidia-gl-440:i386 (= 440.33.01-0ubuntu1)
E: Unable to correct problems, you have held broken packages.

と出たので、nvidiaとlibnvidiaをアンインストールした

$ sudo apt remove nvidia*
$ sudo apt remove libnvidia*

askubuntu.com